Email Deliverability Issues to Microsoft Customers

Incident Report for Roundtrip

Resolved

At this time, the Roundtrip team has verified that email sending and receiving traffic is normal, and there is no ongoing incident.

Our email partner Twilio has updated the root cause of this incident as a policy update for Microsoft email receipt, which changed the response code sent for normal email deferrals. This change in policy does not appear to be a signal that there is an ongoing elevated rise in email deliverability issues.

We will continue to monitor the root incident from Twilio - and will respond if further action is required.
Posted Sep 04, 2026 - 09:21 EDT

Investigating

Roundtrip has been made aware of email deliverability issues to Microsoft accounts and customers. This issue is originating from our email delivery partner Twilio. The Twilio engineering team is currently working through the root cause of this issue.

Non-Microsoft email delivery should be working normally and all SMS traffic and Desktop Notifications are unaffected by this incident.

The Roundtrip team is working to understand impacted customers and monitoring communications from Twilio to take any necessary actions. We will update this as we have more information.
Posted Sep 04, 2026 - 08:17 EDT
This incident affected: Notifications.