Inbound calling

Incident Report for Roundtrip

Resolved

The Roundtrip Navigation Center is now 100% up and running, and continuing to work through the remainder of the backlog
Posted Jul 29, 2025 - 13:51 EDT

Monitoring

Our Roundtrip inbound call center began to experience issues receiving inbound calls around 10:22 AM EST. The team has been moved to backup infrastructure and is now receiving inbound calls as of 10:45 AM EST. Our team is now working through the backlog of calls received during that time. You may see elongated wait times over the next few hours as the backlog of calls is reviewed.
Posted Jul 29, 2025 - 11:58 EDT
This incident affected: Navigation Center Calling.